Player does not load

9 replies [Last post]
Joined: 07/20/2009
Points: 7

When trying to view a video, the player appears to load, and sits with the message "Loading player...". I have tried to view using IE and firefox

I dont see anything relevant in the kaltura or apache logs.

Possibly related, after clicking upload in the management console, the page shows only a black box with the "broken image" icon in the center.

Where can I check for more information/logging? Do you think this is server or client side?

FreeBSD 7.2
Apache 2.2.11 w/ mod_rewrite
PHP 5.2.9

Joined: 07/20/2009
Points: 7

No ideas?

Please ask for more information if it will help.

Joined: 04/05/2009
Points: 354

I haven't had a chance to play with the Kaltura CE yet, but I'll try my best to help you out...

Can you post a screen shot and the embed code for the KDP?

Joined: 07/20/2009
Points: 7

swfobject.embedSWF("http://192.168.168.136/kwidget/wid/_1/ui_conf_id/48110/entry_id/1i5ojrn9ts", "kplayer1", "400", "362", "9.0.0", false, null, params);

swfobject.embedSWF("http://192.168.168.136/kwidget/wid/_1/ui_conf_id/48111/entry_id/1i5ojrn9ts", "kplayer2", "400", "362", "9.0.0", false, null, params);

AttachmentSize
kalturauplaod.PNG49.95 KB
kalturaplayer.PNG54.73 KB
Joined: 01/05/2009
Points: 1697

Hi Tim,

  • This actually our first try in FreeBSD - maybe something with you installation wasn't completed ?
  • Can you try and define a custom host name instead of using the ip for installing the kalturaCE ?

Zohar.

Joined: 07/20/2009
Points: 7

I tried using a hostname based URL.

I have gone over the install and requirements again, carefully rebuilt php, etc.

Is there a more detailed list of requirements regarding the player, or someplace I could look for debug info?

Joined: 04/05/2009
Points: 354

Have you tried using a different browser? Can you successfully load the example players on the Kaltura corporate site?

Joined: 01/05/2009
Points: 1697

Hi Tim,

First there is the Pre-installation and installation guide.

Can you install Fiddler or some other sniffer to find out what the are the bad urls?

Joined: 07/20/2009
Points: 7

This issue is resolved, see below.

From kaltura_install.log:

[2009-07-20 19:05:16] going to replace installation relative root in UIConf files
[2009-07-20 19:05:16] replace_uiconfs called, going to replace UIConfs
[2009-07-20 19:05:16] replace uiconfs with command ./run_replace_root.sh php /
[2009-07-20 19:05:16] failed to replace in uiconf files

Most likely a permissions issue. I was able to manually copy ..../content/uiconf.template to ..../content/uiconf

cp -rp uiconf.template uiconf

After doing this, the player loaded.

.
.

From run_replace_root.php:

find ../content/uiconf -name "*.xml" -exec $1 replace_root.php {} $2 \;

It appears the find syntax is not compatible with freebsd -- is this a necessary step?

Joined: 02/22/2009
Points: 97

when you're not installing on server root (meaning your kaltura is at http://yourdomain/videotool/kaltruaCE/index.php)
all the uiconf files (the XMLs) need to be changed so the root path for including swf files (locales/styles) is the relative path after your domain (/videotool/kalturaCE/...)

can you give us the correct syntax under freeBSD ?

Gonen